Intelligent Cloud Services Status

UI slowness in IICS US West 3 Azure Services

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 15:00 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 12:29 PDT

Investigating

Dear MDM SaaS Customers,

Our monitoring systems have detected UI slowness.

We understand the impact this may have on your operations and appreciate your patience as we work diligently to resolve this. We will keep you updated on our progress and provide further information as soon as it becomes available.

REFIDCST2458
Posted Mar 25, 2025 - 12:21 PDT
This incident affected: IICS US West 3 Azure Services (MDM Customer 360 SaaS, MDM Multidomain SaaS, MDM Product 360 SaaS, MDM Reference 360 SaaS, MDM Supplier 360 SaaS).