Intelligent Cloud Services Status

The API Manager Oauth Token API response change

Resolved

An Initial Incident Review has been updated on https://knowledge.informatica.com/s/article/RCA-for-Incident-on-The-API-Manager-Oauth-Token-API-response-change

Informatica is working on identifying further details including final root cause & preventive actions. Upon completion, Informatica will share a detailed incident report.
Posted Feb 06, 2025 - 09:22 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2025 - 08:44 PST

Update

We are working on a resolution at the earliest. We will keep you posted.
Posted Feb 06, 2025 - 07:46 PST

Update

We are continuing to investigate this issue.
Posted Feb 06, 2025 - 07:15 PST

Investigating

The API Manager's OAuth token API response has been modified.
The 'expires_in' field now returns epoch time instead of seconds. The APIs using the Oauth token to authenticate may face failures.
We are actively investigating and working on a resolution
Posted Feb 06, 2025 - 07:08 PST
This incident affected: IICS EM SouthEast 1 Azure Services (Cloud API Manager), IICS Canada Central 1 Azure Services (Cloud API Manager), IICS UK Services (Cloud API Manager), IICS US West 1 Azure Services (Cloud API Manager), IICS NA West 1 Services (Cloud API Manager), IICS NA East 2 Services (Cloud API Manager), IICS Canada Central 1 Services (Cloud API Manager), IICS US West 3 Services (Cloud API Manager), IICS US East 4 Services (Cloud API Manager), IICS US West 5 Services (Cloud API Manager), and IICS US East 6 Services (Cloud API Manager).