Intelligent Cloud Services Status

Issues while accessing Business360 Console on US East 4 Services
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 14:16 PDT
Monitoring
We observed that customers are facing intermittent issues while accessing Business360 Console. Team is actively working on problem identification and will keep the status page updated.
Posted Apr 12, 2024 - 12:01 PDT
This incident affected: IICS US East 4 Services (MDM Customer 360 SaaS, MDM Multidomain SaaS, MDM Product 360 SaaS, MDM Reference 360 SaaS, MDM Supplier 360 SaaS).