Intelligent Cloud Services Status

Issue while accessing MDM SaaS -- US West 3 Services
Resolved
This incident has been resolved.
Posted May 22, 2023 - 04:48 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2023 - 04:36 PDT
Investigating
We are seeing issues while accessing Customer 360, Business 360, Multidomain MDM, Supplier 360, Product 360 and Reference 360 UI.
We are investigating this on priority and shall continue to update on the progress.
Posted May 22, 2023 - 03:51 PDT
This incident affected: IICS US West 3 Services (MDM Customer 360 SaaS, MDM Multidomain SaaS, MDM Product 360 SaaS, MDM Reference 360 SaaS, MDM Supplier 360 SaaS).