Intelligent Cloud Services Status

Brief Login issues for some users in USW3
Resolved
The issue has been resolved and users are able to login normally.
Apologies for any inconvenience caused
Posted Nov 14, 2018 - 03:18 PST
Monitoring
We noticed some users faced issues in logging on to USW3 between 10.20 - 10.40 PM PST. The issue is limited to few users and it is resolved now. Please login to IICS without any issues and reach out to support if you have any concerns
Posted Nov 13, 2018 - 23:23 PST