Intelligent Cloud Services Status

Issues with Reference360 application on IICS US West 3, US East4 Services
Resolved
Issue has been isolated and customers are expected to clear application cache if they hit "Starting up Service" issue for more than a minute. For further help please reach out to Global Customer Support by creating a support case.
Posted Nov 18, 2022 - 12:01 PST
Update
We are observing an intermittent issue with Reference360 and getting a "Starting up Service" message, Users may not able to open the Reference360 application.

The team is actively looking at it.
Posted Nov 18, 2022 - 11:36 PST
Investigating
We are observing an issue with  Reference360 and getting a "Starting up Service" message, Users may not able to open the Reference360 application.

The team is actively looking at it.
Posted Nov 18, 2022 - 11:29 PST
This incident affected: IICS US East 4 Services (MDM Reference 360 SaaS) and IICS US West 3 Services (MDM Reference 360 SaaS).