Intelligent Cloud Services Status

MDM SaaS UI and Services not accessible on IICS US West 3 Azure Services

Resolved

This incident has been resolved.
Posted May 02, 2025 - 17:20 PDT

Monitoring

All services are currently healthy, and we are monitoring them closely
Posted May 02, 2025 - 13:02 PDT

Update

Recovery steps continue to progress. We are keep all options open including but limited to Disaster Recovery. We will provide updates on this page as soon as it is firmed up and we have an ETA for the completion. We appreciate your patience and understanding during this time
Posted May 02, 2025 - 12:06 PDT

Update

Recovery steps are in progress. We will provide updates on this page as soon as the process is complete or we have an ETA for the completion. We appreciate your patience and understanding during this time.
Posted May 02, 2025 - 11:06 PDT

Update

Outage mentioned earlier continues and we continue to work on recovery steps. We will provide updates on this page as soon as the process is complete or we have an ETA for the completion. We appreciate your patience and understanding during this time.
Posted May 02, 2025 - 10:10 PDT

Update

We are currently addressing an issue in collaboration with our vendor. This requires an outage and and we are working to resolve this as quickly as possible. We will provide updates on this page as soon as the process is complete. We appreciate your patience and understanding during this time
Posted May 02, 2025 - 09:30 PDT

Update

We have successfully executed recovery steps and systems are being validated for optimal recovery.
Posted May 02, 2025 - 07:40 PDT

Investigating

The previously anticipated solution was unsuccessful, and efforts to resolve the issue are ongoing.
Posted May 02, 2025 - 07:07 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 02, 2025 - 06:47 PDT

Investigating

Customers are reporting intermittent failure in in accessing the UI pages and jobs getting stuck. Informatica Team is working on fix. We will keep you updated on our progress and provide further information as soon all operations are restored.
Posted May 02, 2025 - 06:26 PDT
This incident affected: IICS US West 3 Azure Services (MDM Customer 360 SaaS, MDM Multidomain SaaS, MDM Product 360 SaaS, MDM Reference 360 SaaS, MDM Supplier 360 SaaS).